iDevGames Forums

Full Version: Allegro how the hell do you install it??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.


I want to try my hand at allegro, but am confused as to how to install it! I am a complete dope about using the terminal window, and try to avoid it at all costs.

Please someone give me a step by step instruction on how to install it.

I tried it myself and used the commands listed on the documents. It says no such directory exists, so I wrote the path to the src folder for mac osx, then wrote the commands and pressed return. An arrow shows and I wrote the other commands like make depend etc, but after pressing return it kept showing the arrow again?

I hate installing anything with the terminal window!!!Mad
I'm sorry you feel that way, but sometimes it is just necessary. Not so bad once you make some minor effort to learn it.

In other news, every attempt I have made to install Allegro has ended in tears, terminal or no.


Rather than being helpful, You just gave me useless information, thanks for
I'm sorry for giving you the extent of my knowledge and for being polite to you despite your rudeness and excessive use of exclamation points. The information you provided in your first post was too unclear for me to be able to try to diagnose your problem. Specifics would be helpful, such as a link to the instructions and the specific part of the instructions you were trying to follow.

There are tutorials on the command line and a few on Allegro all over the net. For further study, I suggest Google, unless you're ready to stop going after me and start providing some useful information.

Edit: quotation marks >> exclamation points. oops.
In general, posting the error you receive is one of the best ways to help someone else help you. Very few of us can read your mind effectively to determine exactly what you typed or what error message was displayed.
Try this.

Note that the allegro template is installed into the xcode 2.5 location. If you use leopard you will need to move it.
Hi I'm a noob.

I am also having trouble with allegro. I have followed several tutorials:

With the last one, I managed to get the black screen come up as per the tutorial.
However I am unsure how to work with Allegro within Xcode.
I get a file not found error when trying to compile this:

I am also new to Xcode, I think I have to somehow tell xcode where to find allegro. Which i believe is shown in the later part of that youtube vid, although the resolution isnt great and I'm using a newer version of Xcode. Incidentally I have allegro installed as a framework as well, as I believed this would make it easier to use within Xcode - although I do not know if that is true.

The only reason I want to install Allegro is to go through the Tic Tac Toe, Pong tutorials on that web site. I have no clue if it will be useful in the future.


[Image: allegro1.png]
[Image: allegro2.png]
note. because of the forum width, you may need to right click and open into a new tab/window to see the whole image.

I think Ive manage to achieve the linking to allegro as per the youtube vid, see above screen shots. and change the include line. However I am now getting new erros (see image).

Q. Does it look like I have solved the allegro problem?
Q. Are these new errors a problem with the original tictactoe code that I need to somehow resolve?

cheers in advance to anyone who may help.

You need to link to Allegro. In Xcode 4, select the name of the project from the project navigator to open the project editor. Select the target from the left side of the project editor. Click the Build Phases button at the top of the project editor. Click the disclosure triangle next to the Link Binary with Libraries build phase. Click the + button to add Allegro.

I have not used Allegro so I can't provide any more help for you. For future reference if you have a question, start a new thread instead of resurrecting threads that are several years old.
Yeah thanks. I actually managed to get it sorted.

You need to put in paths for the header (see image), in the build settings:

[Image: allegro-paths.png]

For anyone who is interested, the paths are:

/Library/Frameworks/AllegroTTF-5.0.framework/Versions/Current/Headers usr/local/include
Reference URL's