Updating to OS 3.0 SDK

Member
Posts: 50
Joined: 2008.06
Post: #1
I have an app that was built using 2.0 SDK. It runs on 3.0 as is just fine. I want to update and add some features, so I switched to having it build with the 3.0 SDK. Now when it runs, it just displays a white screen (UI is from a NIB built in Interface Builder). Any ideas where to start looking for the cause?
Quote this message in a reply
Moderator
Posts: 613
Joined: 2004.09
Post: #2
Are you by chancing using a navigation bar?

Kyle Richter
DragonForged.com
Twitter: @kylerichter
Quote this message in a reply
Member
Posts: 50
Joined: 2008.06
Post: #3
Nope. I'm using a UIViewController with a UIView With a handful of buttons and a background.

I tried creating a new project (make sure it's all set for OS 3 instead of just changing the base SDK) and it gets the same problem. Maybe I need to redo the nibs?
Quote this message in a reply
Member
Posts: 50
Joined: 2008.06
Post: #4
I wonder if GCC 4.2 changes something in how it works... It seems to be the difference between working and not for someone else trying to use Unity (I'm not using unity, but maybe it's the same problem?). I can't seem to get GCC 4.0 to build properly on Snow Leopard. I get Syntax error before 'AT_NAME" token in the pfix.pch file.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Updating the iPhone SDK/Xcode the_wandering_monster 3 3,657 Dec 12, 2009 06:54 PM
Last Post: Gillissie
  Updating by time haudio 1 1,952 Jan 11, 2009 04:00 PM
Last Post: AnotherJake