Need help with undefined symbols error with Univeral app running under 10.3.9

Nibbie
Posts: 1
Joined: 2009.05
Post: #1
Rather than bringing an old thread back to life...
Quote:http://www.idevgames.com/forum/showthread.php?t=13127

I am getting those same errors on a ppc 10.3.9 machine when my program is built on an intel 10.5.7 machine, problem did not occur when built on machine when it was 10.4.

I'm using a custom makefile to build ppc with g++-3.3, and i386 with g++-4.0.

Some searching online got me more stuff to try, but nothing has changed the results.

Currently (borrowing from some Boinc code i found somewhere):
Code:
PPC_CPPFLAGS = -arch ppc -D_NONSTD_SOURCE -isystem /Developer/SDKs/MacOSX10.3.9.sdk
PPC_LDFLAGS = $(PPC_CPPFLAGS) -W1,-syslibroot,/Developer/SDKs/MacOSX10.3.9.sdk

I386_CPPFLAGS = -arch i386 -D_NONSTD_SOURCE -isystem /Developer/SDKs/MacOSX10.4u.sdk -mmacosx-version-min=10.4
I386_LDFLAGS = $(I386_CPPFLAGS) -W1,-syslibroot,/Developer/SDKs/MacOSX10.4u.sdk

... and the following exports occur before building ppc ...

Code:
    export MACOSX_DEPLOYMENT_TARGET=10.3
    export NEXT_ROOT=/Developer/SDKs/MacOSX10.3.9.sdk
    export SDKROOT=/Developer/SDKs/MacOSX10.3.9.sdk

... and before i386 ...

Code:
    export MACOSX_DEPLOYMENT_TARGET=10.4
    export NEXT_ROOT=/Developer/SDKs/MacOSX10.4u.sdk
    export SDKROOT=/Developer/SDKs/MacOSX10.4u.sdk


The biggest issue I think I'm having is that none of that ^^^ does anything. Tried changing all instances of "/Developer/SDKs/MacOSX10.3.9.sdk" to a non-existent directory, and no warnings or errors occur.

How else can I force g++-3.3 to use the /Developer/SDKs/MacOSX10.3.9.sdk? Or is there another cause for the errors I get that I'm not aware of?

Thanks
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Error with Linking Symbols Oddity007 1 2,743 Feb 24, 2009 06:20 PM
Last Post: Oddity007
  Need help with undefined symbols error with Univeral app running under 10.3.9 Malarkey 1 3,168 Nov 12, 2006 12:23 PM
Last Post: OneSadCookie
  'Undefined Symbols' problem with Xcode 2.3. Any ideas, please!! scratt 6 5,939 Jun 11, 2006 10:19 AM
Last Post: scratt
  'Unidentified error' error in Xcode scgames 2 3,756 Jun 10, 2006 01:38 AM
Last Post: scgames
  Undefined References vbuser1338 13 5,342 Feb 2, 2006 06:40 AM
Last Post: Dingo