ChangeInputMode error in Xcode 3.1 programming in C

Member
Posts: 21
Joined: 2009.05
Post: #1
Hello guys,

Back a few years ago when I was learning C, I developed a text based RPG. I wanted to look over my code and play the game a bit, though I can't get it to build. I programmed the game on Xcode 2.x and am now on Xcode 3.1.2 on OSX 10.5.6 (I programmed the game on OSX 10.4.x).

This is the error I'm receiving and I have no idea how to fix it:

collect2: id returned 1 exit status
symbol(s) not found
_PlayerQuestion in main.o
"_ChangeInputMode", referenced from: (it doesn't say anything. long blank)


The last line concerning ChangeInputMode is what has the error icon. I'm not sure about the first three lines (not warnings or errors).

Thanks for any / all help you are willing to give.

~Achi
Quote this message in a reply
Member
Posts: 21
Joined: 2009.05
Post: #2
Hey guys,

I figured out what I was doing wrong. Since I'm just barely getting back into C and my RPG is several thousand lines of code, I didn't know where to start with debugging. Anyway, ChangeInputMode is a function I was trying to call in my code. The only thing is, the function was never created . . . I must have stopped programming right in the middle of implementing the new feature. Anyway, if you receive an error similar to the above, do a search for the function name and make sure everything is linked up correctly. Smile

~Achi
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Xcode error? bronxbomber92 2 2,492 Nov 2, 2006 07:48 PM
Last Post: bronxbomber92
  Friend error in C++ with Xcode dormlock 6 3,834 Feb 13, 2006 10:05 PM
Last Post: dormlock