Xcode 3.0 crashes on project load

Moderator
Posts: 682
Joined: 2002.11
Post: #1
Whenever I open any project in Xcode, it freezes and I have to force quit. Leopard is up to date, I have no extensions/templates/etc installed, and I reinstalled Xcode once. Even the examples don't work. I did try deleting the preferences.

Any ideas? I searched the mailing lists and came up with no solutions that I hadn't already tried.

My web site - Games, music, Python stuff
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #2
Xcode 3.0 hangs for up to about 5 minutes on some project openings. I'm not sure if that's a 64-bit thing (in which case ticking the "open in 32-bit mode" in the Finder may help) or whether it's a more-than-two processors thing. Your MBP specs suggest the former.

Of course, you could have found a hang which doesn't end, in which case filing a bug report and recreating your project from scratch (or using a sane build system) is probably in order.
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #3
Whoops, misread the post as "my" not "any" :/

I assume you've deleted your preferences, that being the obvious thing missing from your list...
Quote this message in a reply
Moderator
Posts: 682
Joined: 2002.11
Post: #4
OneSadCookie Wrote:Whoops, misread the post as "my" not "any" :/

I assume you've deleted your preferences, that being the obvious thing missing from your list...
I did try that. Post duly edited.

My web site - Games, music, Python stuff
Quote this message in a reply
Member
Posts: 245
Joined: 2005.11
Post: #5
Have you tried repairing permissions? Xcode might be waiting for something that doesn't have permission to launch. You could also watch the Activity Monitor as you open a project - you might see something pop up there to give you a clue.
Does this happen when you create a new project too? I imagine it would but you never know.
Quote this message in a reply
Moderator
Posts: 682
Joined: 2002.11
Post: #6
It happens with every project.

Looks like OSC was right about the five minute delay. Projects do open after five minutes or so. I haven't tried running in 32 bit mode yet. News at eleven.

My web site - Games, music, Python stuff
Quote this message in a reply
⌘-R in Chief
Posts: 1,261
Joined: 2002.05
Post: #7
Anyone sampled it to see what it's doing?
Quote this message in a reply
gevapatz
Unregistered
 
Post: #8
Try disabling distributed builds in your XCode preferences. Open the relevant preference pane and make sure that all the check boxes are not checked (including the 'Bonjour' checkbox. This fixed the problem for me in XCode 3.0.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  SDL Project Stationary for Xcode Evan Stallings 11 4,812 Jul 9, 2013 05:17 PM
Last Post: Evan Stallings
  Converting unix SDL project to xcode Dominus 0 4,303 Jan 3, 2011 04:46 AM
Last Post: Dominus
  Debugging in XCode without project? mattz 5 6,096 Dec 5, 2009 01:21 PM
Last Post: bronxbomber92
  I would like to be able to browse an xCode project on my PC aerospaceman 8 7,218 Jun 29, 2009 07:11 PM
Last Post: aerospaceman
  Cannot load NSData from NSUserDefaults groffhibbitz 1 3,685 Jun 25, 2009 10:25 PM
Last Post: SethWillits