Launching app store from app

Member
Posts: 73
Joined: 2009.03
Post: #1
I am following the instructions on Apple's site here http://developer.apple.com/iphone/librar...a1629.html

However, the URL that I get from iTunes, then replacing itunes with phobos, results in a 404 error. Does anyone know if that document is outdated? Is there a different URL I should be using to link to my app?

Thanks.
Quote this message in a reply
Member
Posts: 73
Joined: 2009.03
Post: #2
Nobody else has any problems linking to an app in the store from an app? Can someone that is successfully doing this please tell me if there is something I should be doing different than the instructions on Apple's site?
Quote this message in a reply
Member
Posts: 43
Joined: 2009.10
Post: #3
Question: Are you actually testing it from the device? If you're trying the link from your computer I don't think it will work. I think phobos is an indicator to the device to launch the app store.

If you are testing from the device and its failing I'd try maybe using the old itunes version of the link.
Quote this message in a reply
Member
Posts: 73
Joined: 2009.03
Post: #4
From the device and from the simulator. The simulator launches Safari and results in a 404. The device launches the app store and results in an error message in the app store.

I finally got a possibly useful response from Apple about this. They referred me to another page that has additional information about links that don't work. Of course, they tried to charge me for a Technical Support Incident first. Rolleyes

http://developer.apple.com/iphone/librar...a1633.html

I'll let you know if I have any luck after going through this info.
Quote this message in a reply
Member
Posts: 73
Joined: 2009.03
Post: #5
The above-referenced URL has information about alternative URL's that may work. I found that using the URL format: itunes.com/apps/<appname> works, but not before a couple of redirects (Sarfari->iTunes->App Store).

I have submitted a bug report for the original URL not working, as instructed by the instructions on the page.
Quote this message in a reply
Member
Posts: 43
Joined: 2009.10
Post: #6
Hey,

So I'm working on getting a lite version of my App out there and I finally tried my buy now link that should go straight to the app store.

As you found, switching the URL from itunes.apple... to phobos.apple did not work. However, If I just kept the original URL it worked correct and went straight to the App store, and not Safari first. Here is the code I'm using for my App Berserker to get this to work:

Code:
NSString *iTunesLink = @"http://itunes.apple.com/us/app/berserker/id346963333?mt=8";
                
[[UIApplication sharedApplication] openURL:[NSURL URLWithString:iTunesLink]];


I noticed however that the link format I use is different than what the Apple article you linked to (the one that says to use phobos) says to use beyond even the phobos change. Mine is just the straight link that I got out of iTunes. All I did was go to iTunes, search for the App, go to the app's page, and then I right clicked on the App name (Berserker in this case) and chose copy link. Then I pasted that in.

See if this works for you. Also what is the explicit App URL you're trying to get it work with, maybe there is something wrong in the format of that?
Quote this message in a reply
Member
Posts: 24
Joined: 2009.08
Post: #7
that's the way I did it. works fine.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Error Launching Remote Program after updating XCode and iPod Madrayken 2 6,145 Oct 14, 2009 03:33 PM
Last Post: Madrayken