/usr/lib problems again...

Member
Posts: 277
Joined: 2004.10
Post: #1
Ok, now I've got libcurl.2.dylib and libssl.0.9.7.dylib "sybolicly linked" from /sw/lib to /usr/lib...

Now, I'm getting this error:
Code:
dyld: /Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag Undefined symbols:
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _btowc expected to be defined in /usr/lib/libSystem.B.dylib
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _iswctype expected to be defined in /usr/lib/libSystem.B.dylib
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _mbsrtowcs expected to be defined in /usr/lib/libSystem.B.dylib
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _towlower expected to be defined in /usr/lib/libSystem.B.dylib
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _towupper expected to be defined in /usr/lib/libSystem.B.dylib
/Users/nathan/Desktop/BZFlag/BZFlag-2.0.2 copy.app/Contents/MacOS/bzflag undefined reference to _wcscoll expTrace/BPT trap

I was read that you need the latest developer tools...???
I have 10.2.8 and the developer tools...
And, I know that it should work fine on Panther...
(libcurl needs to be installed along with libssl for bzflag to work... that's only on Panther...)
I'll continue working with it maybe it was the "sybolic link" (terminals ln command)

Global warming is caused by hobos and mooses
Quote this message in a reply
Member
Posts: 116
Joined: 2002.04
Post: #2
What OS version were those libs compiled on and what version are you trying to run them on?

Wade
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #3
You need to rebuild bzflag on 10.2. Nothing else you do will fix those errors.
Quote this message in a reply
Member
Posts: 277
Joined: 2004.10
Post: #4
Ok,
That's what I thought but I haven't had time to re-comile it...

Also, will the "new" compiled version work on Panther???
I don't want to have to let the bzflag dev people release a different version for
all the Jaguar users out there...

Global warming is caused by hobos and mooses
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #5
Yes, the version built on 10.2 should work fine on 10.3+
Quote this message in a reply
Member
Posts: 277
Joined: 2004.10
Post: #6
Niiiiiiiiiice!!!

THANK YOU SOOOOO MUCH GUYS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Global warming is caused by hobos and mooses
Quote this message in a reply
Post Reply