Weird GLUT problem

Post: #1
I am using glutGameMode. I set up my rendering function via glutDisplayFunc(), and I go into glutMainLoop()óbut sometimes when I run it, the DisplayFunc is not getting called! At first I thought my rendering code was buggy, but then I used SysBeep() to figure out that GL isn't calling my rendering function in the first place. Sometimes it works, sometimes it doesn't. I tried reinstalling OpenGL and linking to a different glut.lib, but nothing helps. I am using system 9 with CodeWarrior IDE 4.04. Any ideas?

Thanks in advance!
Quote this message in a reply
Posts: 5,143
Joined: 2002.04
Post: #2
My recollection is that GLUT's game mode is only partially implemented on MacOS9. It's certainly severely lacking on MacOSX. Are you checking glutGameModeGet(GLUT_GAME_MODE_POSSIBLE) before glutEnterGameMode()?
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Weird problem in xcode SDL skrew 3 4,830 May 27, 2006 08:43 AM
Last Post: Greywhind
  annoying mouse clicks and GLUT problem WhatMeWorry 1 3,440 Nov 6, 2005 01:12 AM
Last Post: OneSadCookie
  GL/GLUT texture alpha problem Joseph Duchesne 3 5,616 Jul 17, 2004 11:02 AM
Last Post: PowerMacX
  Weird SDL problem. Skorche 3 4,554 Jan 19, 2004 12:51 PM
Last Post: Skorche
  Weird framerate problem Jesse 4 4,864 Sep 1, 2003 01:01 AM
Last Post: Jesse