Xcode 4 migration woes..

Member
Posts: 48
Joined: 2011.03
Post: #1
Hi Everyone. Sitting on my desk is a copy of "Xcode 4 Transition Guide". I've skimmed through it but I doubt its going to solve this problem.

I had a perfectly good Xcode 3.2.5 project that compiled and linked. Now when I try to build it on Xcode 4, I get the following error:

Code:
Invalid value '4.0' for GCC_VERSION

I've looked through numerous configuration screens and I can't find a compiler setting that would allow me to specify the GCC version anywhere.

Has anybody else experienced this or know how to fix it please?

I also have a load of warnings as shown below too so that would be my next question Annoyed
Code:
Unable to determine concrete GCC compiler for file /Work/blah/bme.cpp of type sourcecode.cpp.cpp
Unable to determine concrete GCC compiler for file /Work/blah/test.mm of type sourcecode.cpp.objcpp

I'm hoping the warnings will disappear once I find out the answer to the GCC_VERSION error.
Quote this message in a reply
⌘-R in Chief
Posts: 1,248
Joined: 2002.05
Post: #2
Click on the project in the navigator on the left, then click on the Build Settings tab in the main view. Scroll down/search for "C/C++ Compiler Version". Keep in mind that you can set it at both the project and target level. Set in the project and double-check that the target doesn't override it.
Quote this message in a reply
Member
Posts: 48
Joined: 2011.03
Post: #3
(Mar 29, 2011 11:00 AM)SethWillits Wrote:  Click on the project in the navigator on the left, then click on the Build Settings tab in the main view. Scroll down/search for "C/C++ Compiler Version". Keep in mind that you can set it at both the project and target level. Set in the project and double-check that the target doesn't override it.

Excellent, Seth. I double-clicked on the project, clicked on Advanced under Build Settings and changed the compiler from 4.0 to 4.2 and sure enough it builds. Thanks very much for that! Smile
Quote this message in a reply
Nibbie
Posts: 1
Joined: 2013.09
Post: #4
(Mar 29, 2011 11:00 AM)SethWillits Wrote:  Click on the project in the navigator on the left, then click on the Build Settings tab in the main view. Scroll down/search for "C/C++ Compiler Version". Keep in mind that you can set it at both the project and target level. Set in the project and double-check that the target doesn't override it.


Thank You its Working Smile
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  XCode Woes DesertPenguin 4 4,080 Sep 11, 2007 01:22 PM
Last Post: TomorrowPlusX
  XCode woes icklefrelp 5 4,578 Jan 30, 2007 12:05 PM
Last Post: OneSadCookie
  XCode 2.0 linker woes ( Tiger ) TomorrowPlusX 2 3,375 May 2, 2005 07:20 AM
Last Post: TomorrowPlusX