unable to load app with loader

Posts: 164
Joined: 2010.10
Post: #1
i'm trying to submit my app, i have builded in simulator, then click on the xcode folder products, right click on myapp.app show in finder, zipped that file and used loader to upload.

but i receice this issues:
iphone/ipod touch: application executable is missing required architecture. at least one of the following must be present: armv6
>>but if i click on the project->targets in architecture i have standard(armv6 armv7)
icon dimension (58x58) don't meet the size requirements. the icon must be 57x57
>>the icon was 58x58, so i have made it 57x57 but still get this error

application failed codesign verification. the signature was invalid, or it was signed with an apple submission certificate
>>i made a new app store distribution profile and putted in code sign->debug but still this error occours

any ideas?
Quote this message in a reply
Posts: 353
Joined: 2002.04
Post: #2
You need to build for a device, not the simulator.
Quote this message in a reply
Posts: 164
Joined: 2010.10
Post: #3
builded to a device, and set to release
it solved the problem of icon and target archtecture, remain codesign

i have sett on codesign identity:
iphone developer: team provisioning profile
iphone distribution: myapp app store distribution

following this steps:
i have armv6 error
but solved setting "build active architecture only" to "NO"
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Best/simplest way to load data from disk NCarter 9 6,121 Aug 8, 2003 10:12 AM
Last Post: Jesse